diff --git a/Android.mk b/Android.mk
index 7789619f399ca516aeef5ddd674c234b98518e12..f4a09e8351316639add176ab7e4039002a0ffcf0 100644
--- a/Android.mk
+++ b/Android.mk
@@ -14,7 +14,13 @@ LOCAL_RENDERSCRIPT_TARGET_API := 18
 LOCAL_RENDERSCRIPT_COMPATIBILITY := 18
 LOCAL_RENDERSCRIPT_FLAGS := -rs-package-name=android.support.v8.renderscript
 
-LOCAL_SRC_FILES := $(call all-java-files-under, src) $(call all-renderscript-files-under, src)
+# Keep track of previously compiled RS files too (from bundled GalleryGoogle).
+prev_compiled_rs_files := $(call all-renderscript-files-under, src)
+
+# We already have these files from GalleryGoogle, so don't install them.
+LOCAL_RENDERSCRIPT_SKIP_INSTALL := $(prev_compiled_rs_files)
+
+LOCAL_SRC_FILES := $(call all-java-files-under, src) $(prev_compiled_rs_files)
 LOCAL_SRC_FILES += $(call all-java-files-under, src_pd)
 
 LOCAL_RESOURCE_DIR += $(LOCAL_PATH)/res