From 7e199551b7d45767d7a76de35c00f299bea04652 Mon Sep 17 00:00:00 2001
From: Leena Winterrowd <lenhardw@codeaurora.org>
Date: Wed, 13 Aug 2014 12:00:39 -0700
Subject: [PATCH] SnapdragonCamera: Fix static library name conflict

A JNI lib is built for both the Camera2 app and SnapdragonCamera
but is included in system/lib. Since this lib has been branched
as well, rename it and explicitly bundle it with the app to avoid
the library name conflict.

Change-Id: I3177d0a99be06cef0b841d8e84e652b8974cadc6
---
 Android.mk     | 6 +++---
 jni/Android.mk | 4 ++--
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/Android.mk b/Android.mk
index 393068fc6..c51a8a633 100644
--- a/Android.mk
+++ b/Android.mk
@@ -27,13 +27,13 @@ LOCAL_PACKAGE_NAME := SnapdragonCamera
 
 LOCAL_PROGUARD_FLAG_FILES := proguard.flags
 
-# If this is an unbundled build (to install seprately) then include
+# If this is an unbundled build (to install separately) then include
 # the libraries in the APK, otherwise just put them in /system/lib and
 # leave them out of the APK
 ifneq (,$(TARGET_BUILD_APPS))
-  LOCAL_JNI_SHARED_LIBRARIES := libjni_mosaic libjni_tinyplanet
+  LOCAL_JNI_SHARED_LIBRARIES := libjni_snapcammosaic libjni_snapcamtinyplanet
 else
-  LOCAL_REQUIRED_MODULES := libjni_mosaic libjni_tinyplanet
+  LOCAL_REQUIRED_MODULES := libjni_snapcammosaic libjni_snapcamtinyplanet
 endif
 
 include $(BUILD_PACKAGE)
diff --git a/jni/Android.mk b/jni/Android.mk
index b9bafcf6c..af2d81462 100755
--- a/jni/Android.mk
+++ b/jni/Android.mk
@@ -56,7 +56,7 @@ LOCAL_LDFLAGS := -llog -lGLESv2
 
 LOCAL_MODULE_TAGS := optional
 
-LOCAL_MODULE    := libjni_mosaic
+LOCAL_MODULE    := libjni_snapcammosaic
 include $(BUILD_SHARED_LIBRARY)
 
 # TinyPlanet
@@ -65,7 +65,7 @@ include $(CLEAR_VARS)
 LOCAL_CPP_EXTENSION := .cc
 LOCAL_LDFLAGS   := -llog -ljnigraphics
 LOCAL_SDK_VERSION := 9
-LOCAL_MODULE    := libjni_tinyplanet
+LOCAL_MODULE    := libjni_snapcamtinyplanet
 LOCAL_SRC_FILES := tinyplanet.cc
 
 LOCAL_CFLAGS    += -ffast-math -O3 -funroll-loops
-- 
GitLab