From 1f2a3ddb99ef6163b4e0bba78bde8f9bc0f5019b Mon Sep 17 00:00:00 2001
From: xianming wang <mingwax@codeaurora.org>
Date: Fri, 16 Mar 2018 17:27:59 +0800
Subject: [PATCH] SnapdragonCamera: Change the apk support both 64bit and
 32bit.

Change the apk`s makefile to support both 64bit and 32bit.

CRs-Fixed: 2206094
Change-Id: I2acd2e48416ebd7363906079d5fe0c3fbce4fc08
---
 Android.mk | 11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)

diff --git a/Android.mk b/Android.mk
index 186f19672..fb11bf464 100755
--- a/Android.mk
+++ b/Android.mk
@@ -27,23 +27,20 @@ LOCAL_PRIVILEGED_MODULE := true
 
 #LOCAL_SDK_VERSION := current
 LOCAL_RENDERSCRIPT_TARGET_API := 23
-LOCAL_MULTILIB := 32
 
 #LOCAL_OVERRIDES_PACKAGES := Camera2
 
 LOCAL_PROGUARD_FLAG_FILES := proguard.flags
 
-LOCAL_MULTILIB := 32
-
 # If this is an unbundled build (to install separately) then include
 # the libraries in the APK, otherwise just put them in /system/lib and
 # leave them out of the APK
 
-#ifneq (,$(TARGET_BUILD_APPS))
+ifneq (,$(TARGET_BUILD_APPS))
   LOCAL_JNI_SHARED_LIBRARIES := libjni_snapcammosaic libjni_snapcamtinyplanet libjni_imageutil
-#else
-#  LOCAL_REQUIRED_MODULES := libjni_snapcammosaic libjni_snapcamtinyplanet libjni_imageutil
-#endif
+else
+  LOCAL_REQUIRED_MODULES := libjni_snapcammosaic libjni_snapcamtinyplanet libjni_imageutil
+endif
 
 include $(BUILD_PACKAGE)
 
-- 
GitLab